
 

 
 
 

Using GDSII layout data in Sonnet for RFIC analysis 
 
The Sonnet Professional analysis program can import layout data in GDSII format. 
Together with simulation template and layer mapping files, this is used to link Sonnet 
with RFIC layout tools where no dedicated plug-in integration exists. 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
In this document, we will study the data import and simulation setup.  We will base 
our symmetrical inductor example on the following example technology: 
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The purpose of a template file  
In the Sonnet editor, a "template" project  file is used to provide default technology 
information (layers, materials) and simulation setup (frequencies and analysis settings) 
during data import. It is not required to use a template file, but it makes the analysis 
setup a lot easier if you do more than one analysis with the same technology.  
Any Sonnet project file can also be used as a template file. Whenever you read in a 
GDSII cell later, you can easily use these settings from the template file.  
In our case, we will create a new empty project that we can then use as a template file 
during GDSII data import. 

Creating a template file with layer & material definitions 
In the Sonnet project editor, create a new project and set the desired units, then go to 
the dielectric layer setup (Circuit > Dielectric layers). In the top right of the dialog, use 
the Add Above/Below buttons to add more layers. 

Alternative A: Definition for thick metal analysis 
Different layer definitions are used in Sonnet for a thin metal or thick metal analysis. 
For a discussion of thin metal vs. thick metal, please refer to the Sonnet User's Guide, 
Chapter 19: Thick Metal. For RFIC analysis with narrow gaps in the order of the metal 
thickness, a thick metal analysis will provide more realistic simulation results. For this 
reason, our example will be based on thick metal analysis.  
 
The layer definition for thick metal is intuitive because it accounts for the real metal 
thickness, as seen in the process datasheet. For our sample technology, the thick 
metal dielectric layer stack up looks like this: 

 
The s
and th
dielec
metal
The n
metal

M1 

 

 

M2
 

 

via
- 2 - 

 

tack up shown above is used here because it is intuitive and easy to understand, 
e thin metal stack up can be derived from this very easily. We have defined the 
tric layers between the conductors, and extra dielectric layers where the thick 
resides. 
ext step is to define the metal properties for metal layers M1 and M2. To add 
types, go to Circuit > Metal Types and click the Add button. This brings up the 
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metal definition dialog. Change the metal type from "Normal" to "Thick Metal Model" 
and enter the metal conductivity, the metal thickness and a name. 
 

 
 
In our case, the definitions for M1 and M2 have the same values, so we could define a 
single metal type for both metal layers. However, it is a good idea to define both M1 
and M2 metal definitions for documentation clarity. 

Alternative B: Definition for thin metal analysis 
As an alternative to the thick metal definitions shown before, we could also use thin 
metal EM analysis. This is less accurate if the metal thickness has an effect on the field 
and current distribution, but it simulates faster and requires less memory. In case of 
doubt, you should compare thin and thick metal results to find out which simulation 
approach is the better trade-off for your circuit and requirements. 
 
For thin metal analysis, Sonnet will simulate the conductors with zero height. This 
requires a modified dielectric layer setup and a modified metal type definition. For the 
layer stackup, this means that we leave out the dielectric layers "Oxide at M1" and 
"Oxide at M2", to maintain the 2µm face to face metal distance between M1 and M2. 
For the metal types, use metal Type "Normal" instead of "Thick Metal Model". 
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Some special attention is required to get the right losses (Q factors) with thin metal 
analysis. There is some uncertainty, depending on the circuit, if current is flowing on 
one or two sides of the conductors in the skin effect regime. This is where the 
"Current Ratio" defined in the metal type dialog is important. By default, current in the 
skin effect regime is assumed on one side only (microstrip case). Our experience is 
that for RFIC inductors, a value of CR=1 is more appropriate, resulting in simulated 
higher Q factors / less loss. 

 
 
For a detailed discussion of this topic, please refer to the online help (Help button in 
the metal definition dialog) and the Sonnet User's Guide, Chapter 5 "Metalization and 
Dielectric Loss". Please feel free to contact Sonnet support for a discussion of current 
ratio and RFIC loss. 

Importing the GDSII file to Sonnet 
To import the GDSII file, choose File > Import > GDSII in the Sonnet editor.  
Then, select the GDSII file and enable the thick metal template file that we have 
previously defined.  
 

 
 
When you click Next, you are asked which  cell you want to import. Usually, you can 
go with the default structure, and click Next. Sonnet will now read the GDSII file and 
prompt for the layer mapping. Layer mapping means: where do the GDSII metal and 
via layers go in the Sonnet simulation model. In our example, the layout cell is available 
in GDSII format with the following layer assignments: 



 

 
GDSII layer number  Layer usage 

3   Metal M1 
5   Vias M1 – M2 
1   Metal M2 

 
When we set up the GDSII import for the first time, we need to assign the layer 
mapping between Sonnet and the GDSII layer numbers. This can then be stored and 
re-used for similar projects. In our case, the layer mapping can be determined from the 
dielectric layer configuration that we had used in the template definition. The layer 
numbers are the numbers at the left side, and each thick metal layer will extend 
upwards into the dielectric above. 
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eans that metal M1(GDSII: 3) goes to Sonnet level 2 and metal M2 (GDSII: 1) 
to Sonnet level 4. The via between M1 and M2 (GDSII: 5) goes as a via between 
3 and level 2. For the material, we can choose from the drop down list which 
ins all the metal types defined in our template file. 

 

Note: We have defined 
lossless vias here. Sonnet can 
account for vias loss, but in 
this example we ignore that 
detail. If you are interested in 
via loss, please contact us for 
a detailed application note on 
via loss. 
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In this dialog, order does not matter. If you prefer a different order, you can renumber 
the entries as desired. When the mapping is complete, don't forget to store it to disk. 
This way, you can later use it easily for any other GDSII file with the same process. 
 
Click next to proceed. The next dialog allows to tweak some special options, but we 
just click "Import" to read in the design. When the data import is finished, we get a 
summary of the created simulation model. 
 

 
 
The imported layout is now shown in the Sonnet editor, with the box size and cell size 
taken from the template file. Once you have established typical box and cell size values, 
you can enter these values in the template file, so that they are used automatically. 
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Box and cell size 
The size of the analysis box and the cell size must be configured properly for good 
results. The cell size determines the sampling resolution, so this is the key to high 
precision results. The box size must be large enough to avoid coupling between the 
circuit and the side walls. If you have any questions on these issues, please contact 
Sonnet support for the details. 
Box and cell size are set in the Circuit > Box dialog. If you change the box size and 
want to move your circuit, you can do this easily by first doing Edit > Select All 
(<Ctrl>+<A>) and then moving the circuit with the mouse, or use Modify > Center to 
center it horizontally and/or vertically in the analysis box. 

Subsection type 
For RFIC inductors, the new conformal meshing capability is very useful, because it 
allows to reduce memory and simulation time for curved and diagonal polygons.  
Please refer to the Sonnet User's Guide for more information about conformal 
meshing.  
 
You can enable conformal meshing per polygon, but you can also do Edit >Select All 
and then change all polygons at once: Modify > Metal properties > Fill Type. 
 

 

 

Add ports 
When the geometry including vias is complete and material properties are defined, the 
remaining step is to define ports. In Sonnet, different port types exist, but the most 
common port type is the box wall port. Box walls are well suited for inductor analysis 
because we can easily de-embed the feed line up to the desired reference plane. 
 
To define a box wall port, you must extend each feed line to a box wall. You can do so 
by adding a new  polygon, or by stretching an existing polygon. One easy method to 
stretch: use the "Tools > Reshape" command and drag a window around the edge that 
you want to stretch. Then, use the "Modify > Snap to.." command to snap the edge to 
one of the box walls. 
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To define a box wall port, use the "Tools > Add Port" command and click on the edge 
where the feed line touches the box wall. This adds a box wall port at that location, 
with the positive terminal connected to the feed line and the negative terminal 
connected to the box (ground). 
 
To compensate for the additional length of the feed line, a reference plane shift can be 
applied by using the "Circuit  > Ref. Planes / Cal. Length." menu item. A dialog will be 
displayed where you can enter a reference plane shift for each side of the box. The 
offset value can be a fixed value, or linked to a polygon vertex. The value can be typed 
in or defined by a left button mouse click at the desired location. 
 

 
 
If you need to define a port inside the box with no access to the box wall, you can also 
use an "auto grounded port" which connects to ground automatically (using a via which 
is added at run time and goes down through all layers until it touches the bottom of 
the box). Auto grounded ports can be attached to a polygon edge at any location 
inside the box.  
 
We strongly recommend to use box wall ports when you have lossy bulk layers!  
Auto grounded ports might give invalid results with very lossy substrates.  
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Run analysis to generate S parameters and L/Q plots 
After setting up the simulation model, a typical thick metal circular spiral inductor 
might look like this: 
 

 
 
To set up analysis, use “Analysis > Setup” from the Sonnet xgeom menu. In most 
cases, a ABS sweep over a wide frequency range will be the best choice, e.g. 0.1 – 
15GHz. This typically takes five or six EM simulated frequency points to generate fine 
data output at approximately 300 frequency points in the desired range 0.1-15GHz.  
 
Please don’t forget to enable the advanced solver setting “Q factor accuracy”  
to ensure that ABS results are visually identical to a discrete frequency analysis for Q-
factor values. (Requires Sonnet 10 or later) 
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The example shown here will take 16 minutes and 59MB memory to simulate the 
complete frequency range (full thick metal analysis on P4/2.5GHz) with very fine 
geometry sampling of 2µm at 600µm box size. 
 

 
 

When the simulation is done, you can now use the new equation feature, which allows 
to plot results based on predefined or user defined equations. Sonnet has already 
included equations to plot the series inductance of two port devices (equation name 
inductance2) and the quality factor. To plot these values, bring up the result in the 
emGraph data display, then use Equation > Add equation curve from the emGraph 
menu.  
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Note: You can also plot results of different equations on left and right axis at the same 
time, or plot an equation results as a function of a swept parameter. 

 
It is also interesting to see the current density as a function of frequency. Calculating 
the current density adds a little simulation overhead and slows down simulation a little 
bit, but it is very useful to get a feeling how a circuit works and what cell size is 
appropriate. 
 
Current density at 0.1GHz (no skin effect at this low frequency) 
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Current density at 15GHz (skin effect and current crowding very obvious). Note the 
high edge current that Sonnet conformal meshing shows very accurately. 
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